Zeilenumbrüche beim Erstellen eines Beitrags

      Zeilenumbrüche beim Erstellen eines Beitrags

      Hallöchen zusammen,

      ich hab hier die Erfahrung gemacht, dass ihr nicht nur sehr hilfsbereit seid, sondern auch noch ausgesprochen freundlich. :D Ist ja leider eine Seltenheit bei Internetforen. :/
      pattex hat uns mit der ganzen Zeilenumbruchgeschichte schon einmal sehr weitergeholfen und wir haben nun doch noch eine Kleinigkeit entdeckt, die wir leider nicht selbst lösen konnten. Und zwar gibt es ja beim Erstellen eines Beitrags / einer Antwort unten unter der Eingabebox immer eine Vorschau der vorherigen Beiträge. In diesen sind die automatischen BRs nicht enthalten, weshalb er die Texte dann eben als einen einzelnen Wulst anzeigt. Wir haben es auch schon selbst ausprobiert (anhand der Anleitungen, die uns pattex bereits an anderer Stelle gegeben hat), aber irgendwie müssen wir da Fehler gemacht haben, denn es funktionierte schlicht und einfach nicht.

      Wenn uns hier nochmals jemand aushelfen könnte, wäre das supernett.

      LG, Nova :heiligen:
      Hi! Da bin ich wieder (one man show? :drink: )

      Die Lösung stand quasi schon im letzten Beitrag, nur die Datei war eine andere.

      Quellcode

      1. dazu in der addreply.php folgendes suchen:
      2. Quellcode
      3. else $posts['message'] = $parse->doparse($posts['message'], $posts['allowsmilies'], $posts['allowhtml'], $posts['allowbbcode'], $posts['allowimages']);
      4. und danach einfügen:
      5. Quellcode
      6. if($posts['allowhtml']==1){
      7. $posts['cache']=nl2br($posts['cache']);
      8. $posts['message']=nl2br($posts['message']);
      9. }


      Viel Spaß damit und auf ein baldiges Wiedersehen :daumen:
      GoHome! Arbeitszeitüberwachung! (@iOS AppStore)
      Reminder, Worktime, Arbeitszeit, Arbeit, Ueberwachung, Zeiten, Zeitenstempeln
      :dafür: